Mikrotik

Mikrotik handleidingen

Mikrotik OpenVPN

Maak Certificaten aan voor je OpenVPN Server
Alle geel gemarkeerde velden mag je aanpassen 

/certificate

add name=ca common-name=CA_NAME days-valid=3650 key-size=2048 key-usage=crl-sign,key-cert-sign

add name=server common-name=ServerName days-valid=3650 key-size=2048 key-usage=digital-signature,key-encipherment,tls-server

add name=client common-name=ClientName days-valid=3650 key-size=2048 key-usage=tls-client

 

Certificaten laten tekenen

/certificate

sign ca name=ca-certificate

sign server name=server-certificate ca=ca-certificate

sign client name=client-certificate ca=ca-certificate

 

Certificaten exporteren. (via winbox of met scp kun je ze downloaden)

 

/certificate

export-certificate ca export-passphrase=""

export-certificate client export-passphrase=jewachtwoord

Maak een ip pool aan voor je vpn server.

/ip

pool add name="openvpn-pool" ranges=192.168.8.10-192.168.8.50

 

Profiel aanmaken , zorg dat het local & dns adres klopt met je pool

/ppp

profile add name="openvpn-profile" use-encryption=yes local-address=192.168.8.250 dns-server=192.168.8.250 remote-address=openvpn-pool

secret add name=Jenaam profile=openvpn-profile password=jewachtwoord



Interface aanmaken.

/interface ovpn-server server

set default-profile=openvpn-profile certificate=server-certificate require-client-certificate=yes auth=sha1 cipher=aes128,aes192,aes256 enabled=yes













Basis configuratie file voor je openvpn client.
Plak onderstaande config in een .ovpn file
maak ook een secret.txt aan met daarin je openvpn account gegevens.

 

client

dev tun

proto tcp

remote je-ip-adres of ddns 1194

resolv-retry infinite

nobind

persist-key

persist-tun

ca ca.crt

cert client.crt

key client.key

remote-cert-tls server

cipher AES-128-CBC

auth SHA1

auth-user-pass secret

redirect-gateway def1

verb 3